$re = '/(?:^|\s|[^\w$])([a-z_$][a-zA-Z]*[A-Z][a-zA-Z]*)/m';
$str = 'someCamelCasedString & _someCamelCasedString & $someCamelCasedString. Th
: Foo._someCamelCasedString.bar or Foo[_someCamelCasedString].bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);