re = /(?:^|\s|[^\w$])([a-z_$][a-zA-Z]*[A-Z][a-zA-Z]*)/m
str = 'someCamelCasedString & _someCamelCasedString & $someCamelCasedString. Th
: Foo._someCamelCasedString.bar or Foo[_someCamelCasedString].bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end