package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`ORDER\n(.*)`)
var str = `FILTER
prefix#file
ORDER
abs
FILTER
suffix#.txt
ORDER
RRsize`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}