re = /ORDER\n(.*)/
str = 'FILTER
prefix#file
ORDER
abs
FILTER
suffix#.txt
ORDER
RRsize'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end