$re = '/ORDER\n(.*)/';
$str = 'FILTER
prefix#file
ORDER
abs
FILTER
suffix#.txt
ORDER
RRsize';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);