#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?)\s*(?:\[([^\]]*)\])?$"
Local $sString = "aaaaa [] [ddd]" & @CRLF & _
"[] [ddd]" & @CRLF & _
"aaaaaaaa" & @CRLF & _
"aaaaaaaa []" & @CRLF & _
"aaaaaa [" & @CRLF & _
"aaaa [] ddd" & @CRLF & _
"[a] [b] [c] [d]" & @CRLF & _
"[fff]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")