package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)\s*(?:\[([^\]]*)\])?$`)
var str = `aaaaa [] [ddd]
[] [ddd]
aaaaaaaa
aaaaaaaa []
aaaaaa [
aaaa [] ddd
[a] [b] [c] [d]
[fff]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}