const regex = /^(?<block>(?:[a-z][a-z0-9]*)(?:-[a-z0-9]+)*)(?<element>(?:__[a-z][a-z0-9]*(?:-[a-z0-9]+)*))?(?<modifier>(?:--[a-z][a-z0-9]*)(?:-[a-z0-9]+)*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<block>(?:[a-z][a-z0-9]*)(?:-[a-z0-9]+)*)(?<element>(?:__[a-z][a-z0-9]*(?:-[a-z0-9]+)*))?(?<modifier>(?:--[a-z][a-z0-9]*)(?:-[a-z0-9]+)*)?$', 'gm')
const str = `something-something-something
some-class
some-400
some--class\\\\
1something
anything-else__and--other-things
anything-else__and-and--other-things
block
block__element
block__1element
block__element500
block__element--modifier
long-block__long-element--long-modifier
long-123__long-123--long-123
blocky-mc-block-face
block__element__element
block__element--modifier--modifier
block--modifier--modifier
block--modifier__element
block--modifier-500
block--1modifier
^([a-z][a-z0-9]*)(-[a-z0-9]+)*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}