re = /^(?<block>(?:[a-z][a-z0-9]*)(?:-[a-z0-9]+)*)(?<element>(?:__[a-z][a-z0-9]*(?:-[a-z0-9]+)*))?(?<modifier>(?:--[a-z][a-z0-9]*)(?:-[a-z0-9]+)*)?$/m
str = 'something-something-something
some-class
some-400
some--class\\\\
1something
anything-else__and--other-things
anything-else__and-and--other-things
block
block__element
block__1element
block__element500
block__element--modifier
long-block__long-element--long-modifier
long-123__long-123--long-123
blocky-mc-block-face
block__element__element
block__element--modifier--modifier
block--modifier--modifier
block--modifier__element
block--modifier-500
block--1modifier
^([a-z][a-z0-9]*)(-[a-z0-9]+)*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end