use strict;
my $str = 'something-something-something
some-class
some-400
some--class\\\\
1something
anything-else__and--other-things
anything-else__and-and--other-things
block
block__element
block__1element
block__element500
block__element--modifier
long-block__long-element--long-modifier
long-123__long-123--long-123
blocky-mc-block-face
block__element__element
block__element--modifier--modifier
block--modifier--modifier
block--modifier__element
block--modifier-500
block--1modifier
^([a-z][a-z0-9]*)(-[a-z0-9]+)*';
my $regex = qr/^(?<block>(?:[a-z][a-z0-9]*)(?:-[a-z0-9]+)*)(?<element>(?:__[a-z][a-z0-9]*(?:-[a-z0-9]+)*))?(?<modifier>(?:--[a-z][a-z0-9]*)(?:-[a-z0-9]+)*)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}