import Foundation
let pattern = #"^(?<block>(?:[a-z][a-z0-9]*)(?:-[a-z0-9]+)*)(?<element>(?:__[a-z][a-z0-9]*(?:-[a-z0-9]+)*))?(?<modifier>(?:--[a-z][a-z0-9]*)(?:-[a-z0-9]+)*)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
something-something-something
some-class
some-400
some--class\\
1something
anything-else__and--other-things
anything-else__and-and--other-things
block
block__element
block__1element
block__element500
block__element--modifier
long-block__long-element--long-modifier
long-123__long-123--long-123
blocky-mc-block-face
block__element__element
block__element--modifier--modifier
block--modifier--modifier
block--modifier__element
block--modifier-500
block--1modifier
^([a-z][a-z0-9]*)(-[a-z0-9]+)*
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)