import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)=\"(.*?)(?<!\\\\)\"";
final String string = "time=\"2015-06-21T11:33:26+02:00\" level=\"fatal\" msg=\"Error response from daemon: Conflict. The name \\\"test\\\" is already in use by container XXXXXXXX. You have to delete (or rename) that container to be able to reuse that name.\"";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}