#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<test(?!.+href).+"
Local $sString = "<test abc="xyz_CHCFGRc/abc_CHmnop" href="sdddzus.xml">text</test>" & @CRLF & _
"<test abc="abc_abc>text23</test>" & @CRLF & _
"<test abc="123_ABCc/abc_CHmnoph">text42</test>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")