re = /<test(?!.+href).+/m
str = '<test abc="xyz_CHCFGRc/abc_CHmnop" href="sdddzus.xml">text</test>
<test abc="abc_abc>text23</test>
<test abc="123_ABCc/abc_CHmnoph">text42</test>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end