$re = '/<test(?!.+href).+/m';
$str = '<test abc="xyz_CHCFGRc/abc_CHmnop" href="sdddzus.xml">text</test>
<test abc="abc_abc>text23</test>
<test abc="123_ABCc/abc_CHmnoph">text42</test>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);