package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ *([A-z0-9.]*)\(([0-9]+)\)`)
var str = `..\win32_proceduralmusic.cpp(62) : error C2065: 'CS_USEDEFAULT' : undeclared identifier
..\win32_proceduralmusic.cpp(63) : error C2065: 'CS_USEDEFAULT' : undeclared identifier
..\win32_proceduralmusic.cpp(64) : error C2065: 'CS_USEDEFAULT' : undeclared identifier
..\win32_proceduralmusic.cpp(65) : error C2065: 'CS_USEDEFAULT' : undeclared identifier
..\win32_proceduralmusic.cpp(72) : error C2059: syntax error : '='`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}