use strict;
my $str = '..\\win32_proceduralmusic.cpp(62) : error C2065: \'CS_USEDEFAULT\' : undeclared identifier
..\\win32_proceduralmusic.cpp(63) : error C2065: \'CS_USEDEFAULT\' : undeclared identifier
..\\win32_proceduralmusic.cpp(64) : error C2065: \'CS_USEDEFAULT\' : undeclared identifier
..\\win32_proceduralmusic.cpp(65) : error C2065: \'CS_USEDEFAULT\' : undeclared identifier
..\\win32_proceduralmusic.cpp(72) : error C2059: syntax error : \'=\'';
my $regex = qr/^ *([A-z0-9.]*)\(([0-9]+)\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}