re = /^ *([A-z0-9.]*)\(([0-9]+)\)/m
str = '..\\win32_proceduralmusic.cpp(62) : error C2065: \'CS_USEDEFAULT\' : undeclared identifier
..\\win32_proceduralmusic.cpp(63) : error C2065: \'CS_USEDEFAULT\' : undeclared identifier
..\\win32_proceduralmusic.cpp(64) : error C2065: \'CS_USEDEFAULT\' : undeclared identifier
..\\win32_proceduralmusic.cpp(65) : error C2065: \'CS_USEDEFAULT\' : undeclared identifier
..\\win32_proceduralmusic.cpp(72) : error C2059: syntax error : \'=\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end