#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?U)(?s).*class\s+\w+\s*<.*,.*,.*>.*{"
Local $sString = "class ClazzA<R extends A," & @CRLF & _
" S extends B<T>, T extends C<T>," & @CRLF & _
" U extends D, W extends E," & @CRLF & _
" X extends F, Y extends G, Z extends H>" & @CRLF & _
" extends OtherClazz<S> implements I<T> {" & @CRLF & _
"" & @CRLF & _
" public void method(Type<Q, R> x) { " & @CRLF & _
" // ... code ..." & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")