re = /(?s).*class\s+\w+\s*<.*,.*,.*>.*{/
str = 'class ClazzA<R extends A,
S extends B<T>, T extends C<T>,
U extends D, W extends E,
X extends F, Y extends G, Z extends H>
extends OtherClazz<S> implements I<T> {
public void method(Type<Q, R> x) {
// ... code ...
}
}
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end