const regex = /(?s).*class\s+\w+\s*<.*,.*,.*>.*{/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s).*class\\s+\\w+\\s*<.*,.*,.*>.*{', '')
const str = `class ClazzA<R extends A,
S extends B<T>, T extends C<T>,
U extends D, W extends E,
X extends F, Y extends G, Z extends H>
extends OtherClazz<S> implements I<T> {
public void method(Type<Q, R> x) {
// ... code ...
}
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}