import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s).*class\\s+\\w+\\s*<.*,.*,.*>.*\\{";
final String string = "class ClazzA<R extends A,\n"
+ " S extends B<T>, T extends C<T>,\n"
+ " U extends D, W extends E,\n"
+ " X extends F, Y extends G, Z extends H>\n"
+ " extends OtherClazz<S> implements I<T> {\n\n"
+ " public void method(Type<Q, R> x) { \n"
+ " // ... code ...\n"
+ " }\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}