package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:19|20)\d{2}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\d|3[01])T(?:[01]\d|2[0-3]):[0-5]\d:[0-5]\d(?:Z|-0[1-9]|-1\d|-2[0-3]|-00:?(?:0[1-9]|[1-5]\d)|\+[01]\d|\+2[0-3])(?:|:?[0-5]\d)$`)
var str = `2016-04-14T10:10:11+0000
2016-04-14T10:10:11Z
2016-04-14T10:10:11+0100
2016-04-14T10:10:11+01:00
2016-04-14T10:10:11+01
2016-04-14T10:10:11-0000
2016-04-14T10:10:11-00
2016-00-14T10:10:11+0000
2016-13-14T10:10:11+0000
2016-04-00T10:10:11+0000
2016-04-32T10:10:11+0000
2016-04-01T24:10:11+0000
2016-04-01T00:60:11+0000
2016-04-01T00:00:60+0000
2016-04-01T00:00:00+2400
2016-04-01T00:00:00-2400
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}