import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:19|20)\\d{2}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\\d|3[01])T(?:[01]\\d|2[0-3]):[0-5]\\d:[0-5]\\d(?:Z|-0[1-9]|-1\\d|-2[0-3]|-00:?(?:0[1-9]|[1-5]\\d)|\\+[01]\\d|\\+2[0-3])(?:|:?[0-5]\\d)$";
final String string = "2016-04-14T10:10:11+0000\n"
+ "2016-04-14T10:10:11Z\n"
+ "2016-04-14T10:10:11+0100\n"
+ "2016-04-14T10:10:11+01:00\n"
+ "2016-04-14T10:10:11+01\n\n"
+ "2016-04-14T10:10:11-0000\n"
+ "2016-04-14T10:10:11-00\n\n"
+ "2016-00-14T10:10:11+0000\n"
+ "2016-13-14T10:10:11+0000\n"
+ "2016-04-00T10:10:11+0000\n"
+ "2016-04-32T10:10:11+0000\n"
+ "2016-04-01T24:10:11+0000\n"
+ "2016-04-01T00:60:11+0000\n"
+ "2016-04-01T00:00:60+0000\n"
+ "2016-04-01T00:00:00+2400\n"
+ "2016-04-01T00:00:00-2400\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}