use strict;
my $str = '2016-04-14T10:10:11+0000
2016-04-14T10:10:11Z
2016-04-14T10:10:11+0100
2016-04-14T10:10:11+01:00
2016-04-14T10:10:11+01
2016-04-14T10:10:11-0000
2016-04-14T10:10:11-00
2016-00-14T10:10:11+0000
2016-13-14T10:10:11+0000
2016-04-00T10:10:11+0000
2016-04-32T10:10:11+0000
2016-04-01T24:10:11+0000
2016-04-01T00:60:11+0000
2016-04-01T00:00:60+0000
2016-04-01T00:00:00+2400
2016-04-01T00:00:00-2400
';
my $regex = qr/^(?:19|20)\d{2}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\d|3[01])T(?:[01]\d|2[0-3]):[0-5]\d:[0-5]\d(?:Z|-0[1-9]|-1\d|-2[0-3]|-00:?(?:0[1-9]|[1-5]\d)|\+[01]\d|\+2[0-3])(?:|:?[0-5]\d)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}