# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:19|20)\d{2}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\d|3[01])T(?:[01]\d|2[0-3]):[0-5]\d:[0-5]\d(?:Z|-0[1-9]|-1\d|-2[0-3]|-00:?(?:0[1-9]|[1-5]\d)|\+[01]\d|\+2[0-3])(?:|:?[0-5]\d)$"
test_str = ("2016-04-14T10:10:11+0000\n"
"2016-04-14T10:10:11Z\n"
"2016-04-14T10:10:11+0100\n"
"2016-04-14T10:10:11+01:00\n"
"2016-04-14T10:10:11+01\n\n"
"2016-04-14T10:10:11-0000\n"
"2016-04-14T10:10:11-00\n\n"
"2016-00-14T10:10:11+0000\n"
"2016-13-14T10:10:11+0000\n"
"2016-04-00T10:10:11+0000\n"
"2016-04-32T10:10:11+0000\n"
"2016-04-01T24:10:11+0000\n"
"2016-04-01T00:60:11+0000\n"
"2016-04-01T00:00:60+0000\n"
"2016-04-01T00:00:00+2400\n"
"2016-04-01T00:00:00-2400\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.