using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\(|^)[^\)\(]+(?:\)|$))";
string input = @"ONE|(TWO|(THREE|(mid)|FOUR))|(FIVE|SIX)|SEVEN
ONE|(TWO|(THREE|{0}|FOUR))|[1}|SEVEN
ONE|(TWO|{2})|{1}|SEVEN
ONE|{3}|{1}|SEVEN";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}