$re = '/((?:\(|^)[^\)\(]+(?:\)|$))/m';
$str = 'ONE|(TWO|(THREE|(mid)|FOUR))|(FIVE|SIX)|SEVEN
ONE|(TWO|(THREE|{0}|FOUR))|[1}|SEVEN
ONE|(TWO|{2})|{1}|SEVEN
ONE|{3}|{1}|SEVEN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);