re = /((?:\(|^)[^\)\(]+(?:\)|$))/m
str = 'ONE|(TWO|(THREE|(mid)|FOUR))|(FIVE|SIX)|SEVEN
ONE|(TWO|(THREE|{0}|FOUR))|[1}|SEVEN
ONE|(TWO|{2})|{1}|SEVEN
ONE|{3}|{1}|SEVEN'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end