import Foundation
let pattern = #"((?:\(|^)[^\)\(]+(?:\)|$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ONE|(TWO|(THREE|(mid)|FOUR))|(FIVE|SIX)|SEVEN
ONE|(TWO|(THREE|{0}|FOUR))|[1}|SEVEN
ONE|(TWO|{2})|{1}|SEVEN
ONE|{3}|{1}|SEVEN
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)