using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\+|\-)?\d+(\.\d+)?";
string input = @"sdfhsdfh-78923.3525.235235ksjghdkfgsdgsghsdfgdfg898908fghdfhdhdfh678980dfh
0.12
0000.1245";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}