package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\+|\-)?\d+(\.\d+)?`)
var str = `sdfhsdfh-78923.3525.235235ksjghdkfgsdgsghsdfgdfg898908fghdfhdhdfh678980dfh
0.12
0000.1245`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}