re = /(\+|\-)?\d+(\.\d+)?/
str = 'sdfhsdfh-78923.3525.235235ksjghdkfgsdgsghsdfgdfg898908fghdfhdhdfh678980dfh
0.12
0000.1245'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end