use strict;
my $str = 'I need to use regular expressions to draw all the individual letters from the entire sentence, and the result must be in only one group, it can not be a separate group. E.g:
This is an example sentence in which I have two letters: ';
my $regex = qr/(?s)(?:(?!(?<!\w)\w(?!\w)).)+/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";