import Foundation
let pattern = #"(?s)(?:(?!(?<!\w)\w(?!\w)).)+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
I need to use regular expressions to draw all the individual letters from the entire sentence, and the result must be in only one group, it can not be a separate group. E.g:
This is an example sentence in which I have two letters:
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)