import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\d{1,3}|1\\d{1,3}|20[012][0-3])\\b";
final String string = "1\n"
+ "2\n"
+ "3\n"
+ "4\n"
+ "102\n"
+ "921932\n"
+ "2100\n"
+ "2000\n"
+ "1999\n"
+ "23412\n"
+ "92\n"
+ "41\n"
+ "2022\n"
+ "2021\n"
+ "2023\n"
+ "2024\n"
+ "2025\n"
+ "1998\n"
+ "666\n"
+ "667";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}