import re
regex = re.compile(r"\b(\d{1,3}|1\d{1,3}|20[012][0-3])\b")
test_str = ("1\n"
"2\n"
"3\n"
"4\n"
"102\n"
"921932\n"
"2100\n"
"2000\n"
"1999\n"
"23412\n"
"92\n"
"41\n"
"2022\n"
"2021\n"
"2023\n"
"2024\n"
"2025\n"
"1998\n"
"666\n"
"667")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")