$re = '/\b(\d{1,3}|1\d{1,3}|20[012][0-3])\b/';
$str = '1
2
3
4
102
921932
2100
2000
1999
23412
92
41
2022
2021
2023
2024
2025
1998
666
667';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);