const regex = /\b(\d{1,3}|1\d{1,3}|20[012][0-3])\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d{1,3}|1\\d{1,3}|20[012][0-3])\\b', 'g')
const str = `1
2
3
4
102
921932
2100
2000
1999
23412
92
41
2022
2021
2023
2024
2025
1998
666
667`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}