const regex = new RegExp('^(category)/([^/]+)/([^/]+)/((?:(?!\\bitem\\b).)+)/([^/]+)/?$', 'gm')
const str = `category/all-weather-wicker/bermuda/table/2977/
category/all-weather-wicker/bermuda/item/2977/
category/all-weather-wicker/bermuda/foo/2977/
category/all-weather-wicker/bermuda/item/2977/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}