$re = '~^(category)/([^/]+)/([^/]+)/((?:(?!\bitem\b).)+)/([^/]+)/?$~m';
$str = 'category/all-weather-wicker/bermuda/table/2977/
category/all-weather-wicker/bermuda/item/2977/
category/all-weather-wicker/bermuda/foo/2977/
category/all-weather-wicker/bermuda/item/2977/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);