# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:https?:\\/\\/)?(?:(?:www\.)?youtube\.com\\/(?:(?:v\\/)|(?:embed\\/|watch(?:\\/|\?)){1,2}(?:.*v=)?|.*v=)?|(?:www\.)?youtu\.be\\/)([A-Za-z0-9_\-]+)&?.*$//gmi;t' <<< "https://www.youtube.com/watch?v=L-iepu3EtyE&ab_channel=systemofadownVEVO"