re = /^(?:https?:\/\/)?(?:(?:www\.)?youtube\.com\/(?:(?:v\/)|(?:embed\/|watch(?:\/|\?)){1,2}(?:.*v=)?|.*v=)?|(?:www\.)?youtu\.be\/)([A-Za-z0-9_\-]+)&?.*$/mi
str = 'https://www.youtube.com/watch?v=L-iepu3EtyE&ab_channel=systemofadownVEVO'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result