$re = '`^(?:https?:\/\/)?(?:(?:www\.)?youtube\.com\/(?:(?:v\/)|(?:embed\/|watch(?:\/|\?)){1,2}(?:.*v=)?|.*v=)?|(?:www\.)?youtu\.be\/)([A-Za-z0-9_\-]+)&?.*$`mi';
$str = 'https://www.youtube.com/watch?v=L-iepu3EtyE&ab_channel=systemofadownVEVO';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;