import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\h*(?<name>\\w++)\\h*=.*\\R(?=\\h*(?<good>(?!\\k<name>\\b)\\w++\\h*=.*$))";
final String string = "header line\n"
+ " a = b\n"
+ " c = d\n"
+ " c = e\n"
+ " f = g";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}