const regex = /^\h*(?<name>\w++)\h*=.*\R(?=\h*(?<good>(?!\k<name>\b)\w++\h*=.*$))/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\h*(?<name>\\w++)\\h*=.*\\R(?=\\h*(?<good>(?!\\k<name>\\b)\\w++\\h*=.*$))', 'mg')
const str = `header line
a = b
c = d
c = e
f = g`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}