re = /^\h*(?<name>\w++)\h*=.*\R(?=\h*(?<good>(?!\k<name>\b)\w++\h*=.*$))/m
str = 'header line
a = b
c = d
c = e
f = g'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end