using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[img=\](.*?)\[/img\]";
string input = @"[img width=800,height=531]https://forklog.com/wp-content/uploads/Brisbane-International-Airport.jpeg[/img]";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}