// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?is)\[img=\](.*?)\[/img\]").unwrap();
let string = "[img width=800,height=531]https://forklog.com/wp-content/uploads/Brisbane-International-Airport.jpeg[/img]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}