re = /\[img=\](.*?)\[\/img\]/i
str = '[img width=800,height=531]https://forklog.com/wp-content/uploads/Brisbane-International-Airport.jpeg[/img]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end